Asynchronous Spacewarp

Dieses Thema im Forum "Oculus Rift" wurde erstellt von SolKutTeR, 7. Oktober 2016.

  1. Ich frage mich gerade welche Version ich installiert habe. In Oculus-Home gibt es ja nirgends eine Anzeige dafür, oder habe ich die übersehen? Wenn ich in den entsprechenden Ordner gehe und die Versions-Datei öffne, dann steht da immer noch v1.3.3 (wie bei der Erstinstallation zur CV1 im Mai) . hmmm, komisch.
     
  2. Das SDK brauchen eigentlich nur Entwickler, oder Leute die das Debug Tool nutzen ^^. das Tool funktioniert aber auch mit ner alten Version.
    Die Runtime updated sich eigentlich automatisch. Die Nummer wird in Oculus Home hinter dir am Tresen angezeigt :D
     
  3. Ahh, danke für den Tip :whistle: Hatte angenommen, dass man das auch irgendwo in OculusHome aufm Desktop (ohneVR) sehen kann. Aber gut. So sind die VR-Heinis ;) Habe also v1.9.0.2xxxxx. Das Debug-Tool nutze ich natürlich sowieso immer. Das könnten die so langsam auch mal in Home integrieren :whistle:
     
  4. Das Debug-Tool hat aber noch immer die Version 0.3 also hat sich hier nichts geändert.
     
  5. Ja, denke schon. Bei mir zumindest. Hab noch nichts von einem Update gehört.
     
  6. Hallo,

    ich habe zur Zeit noch eine MSI GTX 960 4GB. Habe die Rift auch erst seit gestern und will mir auch noch eine GTX 1070 kaufen, wollte es jetzt aber trotzdem gerne mal mit der 960 ausprobieren seit dem ich erfahren habe, was ASW leisten kann.

    Wenn ich ASW aktiviere (strg+num3) habe ich aber starkes ruckeln, so als ob er dann gar keine Zwischenbildberechnung vornimmt. (im Layer werden 45Hz angezeigt)
    Das selbe im Automatischen Umschaltmodus (strg+num4). Und genau so ruckelig ist es auch wenn ich ASW anmache aber die Zwischenbildberechnung aus (strg+num2).
    Wenn ich ASW komplett aus mache (strg+num1) läuft es sehr viel besser.

    Wieso geht das denn nicht bei mir? :(

    Treiber sind akuell.
     
  7. Wo hast du denn die Tastenkombinationen her, dachte man müsste ASW in der Registry aktivieren?
     
  8. Ist schon richtig so:
    • CTRL+Numpad1: Deaktiviert ASW
    • CTRL+Numpad2: Apps laufen mit 45Hz, ASW deaktiviert
    • CTRL+Numpad3: Apps laufen mit 45Hz, ASW aktiviert
    • CTRL+Numpad4: Automatische ASW Kontrolle aktivieren
    (ein Hoch auf alle Gaming-Keyboards ohne Num-Block ;) )

    Zum austesten sollte man noch das Oculus-Debug-Tool mit verwenden, um sich die tatsächlich zur VR-Ausgabe gerenderten FPS anzeigen zu lassen, bzw. ob Reserven oder Framedrops vorhanden sind.

    Kommt natürlich auf die Anwendung und Details an, aber die Wahrscheinlichkeit dass es an der GPU-Performance liegt, ist doch relativ hoch. Eine GTX1070 oder besser 1080 wäre auf jeden Fall anzuraten, um für die meisten Fälle gerüstet zu sein :)
     
  9. Mit welcher App hast du es probiert und was meinst du denn mit starken Ruckeln?
    Vielleicht siehst du einfach den Unterschied wie er ist? Native 90fps sind meistens besser. Besonders bei Sachen mit vielen und schnellen Bewegungen. Aber flüssig sollte ASW eigentlich schon wirken.
    Das ist hauptsächlich dafür da, dass du unter 90fps immer noch ein flüssiges Erlebnis hast. Besonders auffällig wird es z.b., wenn bei unter 90fps, direkt vor einem Objekt, deinen Kopf seitlich hin und her bewegst, oder vor und zurück und dabei zwischen strg+NUM1 (ASW aus) und strg+NUM3 (ASW an) wechselst :)
     
    #19 Syndroid, 29. Oktober 2016
    Zuletzt bearbeitet: 29. Oktober 2016
  10. Also ich sehe hier keinen Unterschied wenn ich während des Games (Valkyrie) Strg+Num4 oder Strg+Num1 drücke,
    es ruckelt jeweils gleich stark. Hab im Debug-Tool Pixel auf 2.0 gestellt um das Ruckeln zu forcieren.
    Und wo kann ich mir im Debug-Tool die FPS anzeigen lassen?
     

Diese Seite empfehlen